Java APM Agent 11.1.15 - Better MongoDB support

MongoDB drivers 3.7+ are now fully supported.